User Deprecated Annotation @return should be replaced with native return type

ldown
Člen | 29
+
0
-

Jak můžu vypnout tento trigger_error https://github.com/…Resolver.php#L135 ?

Háže mě to u externích knihoven, kde to těžko ovlivním.

E_USER_DEPRECATED nechci kvůli tomu vypínat.

Editoval ldown (6. 2. 2023 12:53)

nightfish
Člen | 482
+
+1
-
  1. Použít starší nette/di
  2. Aktualizovat externí knihovny (existují-li nové verze)
  3. Použít cweagans/composer-patches pro úpravu kódu ve vendoru (návod)
David Grudl
Nette Core | 8182
+
0
-

Použij starší verzi DI, když nechceš přecházet https://blog.nette.org/…hodova-verze

ldown
Člen | 29
+
0
-

Ani jedna možnost asi není košér:

  1. Nechci plout proti proudu
  2. Asi těžko všechny knihovny nebudou kvůli nette odstraňovat anotace (např AWS ;)
  3. To se mě taky nelíbí :(
David Grudl
Nette Core | 8182
+
+2
-

Tak ten typ doplň do konfigurace.

ldown
Člen | 29
+
0
-

David Grudl napsal(a):

Tak ten typ doplň do konfigurace.

Aha. To je to co jsem hledal ;)