Chyba pri prechode PHP 7.0 → PHP 7.1

Laco
Člen | 7
+
0
-

Zdravím,
z dôvodu závislosti v knižnici som potreboval prechod PHP na 7.1 (7.3 nemám momentálne čas riešiť kvôli problému s object). Po zmene PHP mi začalo vypisovať chybu:

Declaration of Nette\Bridges\ApplicationLatte\SnippetBridge::isSnippetMode() must be compatible with Latte\Runtime\ISnippetBridge::isSnippetMode(): bool

moje závislosti v composer:

	"require": {
		"php": "^7.1",
		"nette/application": "^2.4",
		"nette/bootstrap": "^2.4.2",
		"nette/caching": "^2.5",
		"nette/database": "^2.4",
		"nette/di": "^2.4",
		"nette/finder": "^2.4",
		"nette/forms": "^2.4",
		"nette/http": "^2.4",
		"nette/mail": "^2.4",
		"nette/robot-loader": "^2.4",
		"nette/security": "^2.4",
		"nette/utils": "^2.4",
		"latte/latte": "^2.4",
		"tracy/tracy": "^2.4",
		"radekdostal/nette-datetimepicker": "^2.5",
		"stekycz/Cronner": "^2.1",
		"iio/libmergepdf": "^4.0"
	},
	"require-dev": {
		"nette/tester": "^1.6"
	}
David Matějka
Moderator | 6378
+
0
-

zafixuj latte na 2.4 pomoci constraint ~2.4.0, ted se ti nainstalovalo 2.5

David Grudl
Nette Core | 7445
+
+1
-

Máš tam Latte 2.5.1? Mělo by to fungovat v pohodě.

Laco
Člen | 7
+
0
-

Pomohol mi update latte na v2.5.1, ďakujem