Dependency Injection ve 2.1: Validační schéma pro rozšíření

Upozornění: Tohle vlákno je hodně staré.

před 7 lety

David Grudl
Nette Core | 7148
+
0
-

(Vyčleněno ze staršího příspěvku)

Pokud se překlepnu v identifikátoru v konfiguračním souboru nebo neznám jeho přesnou strukturu, často to nezpůsobí žádnou chybu a klíč se ignoruje. Validační schéma by mělo zajistit striktní kontrolu jeho obsahu.

Nevím, jestli do verze 2.1 stihnu připravit obecný validátor, pokud ne, tak by mohl existovat alespoň jednoduchý pro NetteExtension.

před 7 lety

pekelnik
Člen | 468
+
0
-

Určitě by byl lepší obecný validátor. Důležité je aby měl pěkné API ;)