Errors with diffrent package version names

kena23
Member | 1
+
0
-

Dokazal by nekdo poradit co s timhle prosim?

martin@DESKTOP-CRBEHE9:~/projects/BaseAppQMAN$ docker run --rm --interactive --tty   --volume $PWD:/app composer require contributte/guzzlette "^3.2.0" -W
Info from https://repo.packagist.org: #StandWithUkraine
./composer.json has been updated
Running composer update contributte/guzzlette --with-all-dependencies
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - contributte/guzzlette[v3.2.0, ..., v3.2.3] require nette/di ~3.0.0 -> found nette/di[v3.0.0, ..., v3.0.16] but it conflicts with your root composer.json require (^3.1).
    - contributte/guzzlette v3.2.4 requires nette/utils ^3.1.0 -> found nette/utils[v3.1.0, ..., v3.2.9] but it conflicts with your root composer.json require (^4.0).
    - Root composer.json requires contributte/guzzlette ^3.2.0 -> satisfiable by contributte/guzzlette[v3.2.0, ..., v3.2.4].


Installation failed, reverting ./composer.json and ./composer.lock to their original content.

Last edited by kena23 (2023-04-03 22:32)

nightfish
Member | 463
+
+1
-

Ve svém composer.json vyžaduješ nette/di ve verzi ^3.1 a nette/utils ve verzi ^4.0.
Žádná verze contributte/guzzlette není s těmito verzemi kompatibilní.

Možnosti:

  1. počkat na vydání nové verze contributte/guzzlette
  2. na projektu se vrátit k nette/di:^3.0 a nette/utils:^3.2 a použít guzzlette:^3.2.0
  3. na projektu se vrátit k nette/utils:^3.2 a použít guzzlette@dev-master.
hanna222
Member | 1
+
0
-

I've been getting a lot of bugs lately :/