How do I actually install Nette version 3?

6 months ago

MissGinger
Member | 2
+
0
-

hello people. I have been using Nette 2.* for a week or so now and apart from the lack of English documentation I really like the FW. I do not however know how to install version 3? As far as I am aware “3” was released 3 months ago but nothing other than the announcement on the blog suggests it is actually here.

For example if I go to the following Download link I find the following composer line… composer create-project nette/web-project

Now I would expect that to install Nette 3? But if I go into the composer.json file afterwards I see the following.

{
“name”: “nette/web-project”,
“description”: “Nette: Standard Web Project”,
“keywords”: [“nette”],
“type”: “project”,
“license”: [“MIT”, “BSD-3-Clause”, “GPL-2.0”, “GPL-3.0”],
“require”: {
“php”: “>= 5.6”,
“nette/application”: “^2.4”,
“nette/bootstrap”: “^2.4.2”,
“nette/caching”: “^2.5”,
“nette/database”: “^2.4”,
“nette/di”: “^2.4”,
“nette/finder”: “^2.4”,
“nette/forms”: “^2.4”,
“nette/http”: “^2.4”,
“nette/mail”: “^2.4”,
“nette/robot-loader”: “^2.4 || ^3.0”,
“nette/security”: “^2.4”,
“nette/utils”: “^2.4”,
“latte/latte”: “^2.4”,
“tracy/tracy”: “^2.4”
},
“require-dev”: {
“nette/tester”: “^2.0”
},
“minimum-stability”: “stable”,
“config”: {
“platform”: {
“php”: “5.6”
}
 }
}

That to me suggests it has installed the 2.* branch?

Last edited by MissGinger (2019-06-24 02:18)

6 months ago

MissGinger
Member | 2
+
+1
-

Also there is no migration instructions from 2.4 to 3 on the migration page

6 months ago

Jan Tvrdík
Nette guru | 2563
+
+3
-

Nette 3 requires PHP 7.1+. You probably have an older version which forces Composer to install older version of Nette.

6 months ago

Pavel Kravčík
Member | 995
+
0
-

I would say that problem is here, just remove this part and should be ok.

"config": {
	"platform": {
		"php": "5.6"
	}
}