tracy on remote server does not starts Tracy

about a month ago

jannemec
Member | 62
+
0
-

I have remote server where I need to use tracy and debugger – even if I call \Tracy\Debugger::enable(\Tracy\Debugger::DEVELOPMENT, WWW_DIR . ‘/log’); the error goes to Error page and not to tracy debug – what can be wrong? On the localhost everything goes correctly. Nette 2.4
JN

about a month ago

CZechBoY
Member | 3130
+
0
-

You need to enable debug mode in bootstrap.php or whenever before application is started.

28 days ago

jannemec
Member | 62
+
0
-

I have
\Tracy\Debugger::enable(\Tracy\Debugger::DEVELOPMENT, WWW_DIR . ‘/log’);
/just after the import autoload.php/
in bootstrap.php and no luck …

28 days ago

David Matějka
Moderator | 5650
+
0
-

Hi, by calling Debugger::enable(...) you start just a Tracy in development/debug mode, not the whole nette application.

For running your nette application in a debug mode, you have to place a line

$configurator->setDebugMode(true);

to your bootstrap before a line $configurator->enableDebugger(...)