Nette Utils 2.5 – deprecated Nette\Object

about a month ago

David Grudl
founder | 6728

Nette Utils v2.5 throws an error message when you use the Nette\Object or Nette\Utils\ObjectMixin, ie. classes that were already deprecated in v2.4. You can find out from error message where these classes are used. And it suggests replacing Nette\Object with trait Nette\SmartObject.

These classes are not compatible with PHP 7.2 and will be removed from Nette Utils v3.