Any way to disable noescape by default (Latte standalone)

about a month ago

tpr
Member | 55
+
0
-

I would like to disable the “noescape” filter globally, if this possible somehow? Using latest Latte, standalone version.

about a month ago

David Grudl
founder | 6705
+
0
-

It is not possible.

about a month ago

mkoubik
Member | 732
+
0
-

You can at least extend Latte\Engine and override ->render() to wrap all string (or having ->__toString()) parameters in Latte\Runtime\Html.

But I would strongly disrecommend doing that, why do you need that?

about a month ago

David Grudl
founder | 6705
+
0
-

@mkoubik It is about disable, not enable.

about a month ago

tpr
Member | 55
+
0
-

Thanks, but I wanted something more easily maintanable (eg. when updating).

I'm using it for a CMS module and it seems there's no need for noescape, data comes in more or less sanitized. But perhaps I'll modify the core, I don't update the module too often.