editor:// link in VirtualBox

4 years ago

fmasa
Member | 2
+
+4
-

Hi,
is there any way to manually specify project's root directory for Tracy?

I am using Vagrant, so Tracy uses path /home/vagrant/Code.... But the “real” directory is C:/dev/....

I know you can edit editor link using Debugger::$editor, but that doesn't solve the issue.

Something like:

Debugger::$editorMapping = [
    '/home/vagrant/Code' => 'C:/dev/
];

would be nice.

4 years ago

voda
Member | 562
+
0
-

You can replace it in your editor link handler, something like:

str_replace('/home/vagrant/Code', 'C:/dev/', $uri);

4 years ago

adrianbj
Member | 29
+
0
-

I'd still really love to see an $editorMapping option as proposed by @fmasa – is there a reason this shouldn't be added?

I don't really see how the solution by @voda solves the problem properly – maybe I don't fully understand the suggestion, but it sounds like it is supposed to occur system wide on your machine?

Sorry if I am missing something obvious.

3 years ago

adrianbj
Member | 29
+
+1
-

This has been taken care of: https://github.com/…0bde1320d35c