Zprovoznění Nette na Forpsi hostingu

MajBoss
Člen | 16
+
0
-

Zdravím,
potřebuji rozchodit Nette aplikaci na Forpsi hostingu, bohužel bez úspěchu. Neustále mi to hází error 500, jednou prohližečovej, jednou přímo od Forpsi, jsem z toho úplně zoufalej.

Na lokálu (XAMPP) mi to funguje úplně v pořádku, jen jsem to překopíroval na hosting a nejde vůbec nic.

Nevíte někdo co s tím, čím by to mohlo být? Předem děkuji.

emololftw
Člen | 82
+
0
-

Jenom tipuji:

  1. Využívá aplikace databázi? Co config.local.neon, máš v repositáři na serveru všechny soubory?
  2. Nastavení permissions na temp a log složku
  3. Je verze PHP totožná s localhostem?

Editoval emololftw (25. 7. 2022 13:52)

nightfish
Člen | 475
+
0
-

@MajBoss Žádné relevantní informace jsi neposkytl, takže ti nezbyde než se podívat na vlákna, ve kterých se problémy s Forpsi už řešily: https://cse.google.com/cse?…

A nebo napiš na podporu Forpsi, ti tě třeba budou schopni nasměrovat lépe.

MajBoss
Člen | 16
+
0
-

@nightfish Já totiž nemám moc co více poskytnout, nemám nic bližšího. Tu podporu na Forpsi asi vyzkouším no, nic jiného mi nezbývá.

MajBoss
Člen | 16
+
0
-

emololftw napsal(a):

Jenom tipuji:

  1. Využívá aplikace databázi? Co config.local.neon, máš v repositáři na serveru všechny soubory?
  2. Nastavení permissions na temp a log složku
  3. Je verze PHP totožná s localhostem?

Verze PHP totožná není, Forpsi je bohužel zastaralej a nejnovější co nabízí je PHP 7.4!
Moje aplikace sice běží na 8.1, ale nic z té verze nevyužívá, myslíš, že to může vadit?

Mysteria
Člen | 797
+
+1
-

Tvůj kód sice nic z PHP 8.1 používat nemusí, ale knihovny klidně ano. Tzn. rozjeď si lokálně taky PHP 7.4 a uvidíš, kde je problém hned a nebudeš to muset debugovat na serveru.

Případně můžeš ještě zkusit https://getcomposer.org/…06-config.md#…, tzn. lokálně mít PHP 8.1, ale řekneš composeru, že se má chovat tak, jako kdyby měl PHP 7.4, takže by se ti měli stáhnout verze knihoven kompatibilní s danou verzí PHP.

MajBoss
Člen | 16
+
0
-

Dobrý nakonec vyřešeno přesunutím hostingu na PHP 8.1.

Pavel Kravčík
Člen | 1184
+
+1
-

Composer umí celkem cool věc, třeba Ti to v budoucnu pomůže. ;)