Presentery: property lazy-autowire na steroidech

před 5 lety

wicked
Člen | 290
+
0
-

Zdravím,

mám takový malý dotaz… Mam vlastní VPS, apache2, php 5.4.4 ale když podle návodu nahodit autowired tak mě web hodí interval server error a jediné co mám v logu je

Mon Jun 02 10:21:06 2014] [error] mod_fcgid: process /var/www/php-fcgi-scripts/web7/.php-fcgi-starter(25725) exit(communication error), get unexpected signal 11

Tak se chci zeptat zda někoho něco nenapadá? Všude to běží jen projekty na VPS hází errory, to funguje jen pro některé módy a verze php?

Dekuji

před 5 lety

Filip Procházka
Moderator | 4693
+
0
-

Nenapadá mě důvod proč by to nemělo fungovat. Nemáš tam eAccelerator? Nebo jinou opcode cache, ale blbě nastavenou? Rozšíření je závislé na možnosti číst dokumentační komentáře (většinou jdou v opcache zakázat).

před 5 lety

wicked
Člen | 290
+
0
-

Jediné co mi běží za cache je memcached, php5-memcached a php5-memcache…

Vyřešilo by to asi klasické anotace @inject ale to jsem ještě zatím nezkoušel…

Link na info

Děkuji za rady a napady

Teoreticky, co ještě Xcache?

Editoval wicked (3. 6. 2014 1:07)

před 5 lety

wicked
Člen | 290
+
0
-

Jasné, problém vyřešen :-)

Dělalo to php5-xcache :-)

Děkuji za nakopnutí :-)

před 5 lety

Filip Procházka
Moderator | 4693
+
0
-

Doporučuji upgradovat na 5.5.13 a používat nativní opcode cache.

před 5 lety

wicked
Člen | 290
+
0
-

Php 5.5.13 ještě není stable v Debian repository :-)

Proto frčím na 5.4.4 :-)

před 5 lety

David Matějka
Moderator | 5874
+
0
-

@wicked: http://www.dotdeb.org/ ;) ja teda pouzivam taky php 5.4 ale s apc

před 5 lety

wicked
Člen | 290
+
0
-

@matej21: Je mi jasné, že si PHP 5.5 můžu dodatečně natáhnout, ale chci počkat až vyjde oficiálně ve stable repositarich.

Druhá možnost je ngix ale ten se mi zatím ani nezalibil.

Používáš apc, co přesně tím mas na mysli?

Edit: jasně php-apc :-) a používáš jen toto nebo i memcached, php5-memcached, php5-memcache?

Editoval wicked (3. 6. 2014 14:59)

před 5 lety

David Matějka
Moderator | 5874
+
0
-

memcache* nepouzivam. Apc pouzivam jako opcode cache..

před 5 lety

Jiří Nápravník
Člen | 708
+
0
-

php 5.5 taky zatím nemáme, protože právě není stable na debianu, tak admin nechce zatím. ale opcache se dá dokompilovat i pod PHP 5.4 a celkem spokojene pouzivame

před 5 lety

Filip Procházka
Moderator | 4693
+
+3
-

Admin do toho nemá co kecat, nainstaluje co se mu řekne :) My instalujeme i setinkové verze hned jak vyjdou. Admin taky remcá, ale aplikace je naše, né jeho.

Dupněte si sakra. Tím že jste ochotní běžet na starším než aktuálním stable poškozujete úplně celou PHP platformu, protože jenom díky vám ještě dneska běží hostingy s php 5.2.

A jestli se o tom chcete hádat tak si založte vlastní téma :)

Stránky: Prev 1 2 RSS tématu