Upgrade aplikace z Nette 0.9.8

netcarlos
Člen | 1
+
0
-

Mám takovou starší appku psanou ještě s Nette 0.9.8.. Je reálný upgrade na současné PHP8.1?

Přemýšlím jak to pojmout.. Jestli to celé není třeba přepsat odznovu. Je to appka střední velikosti.

Máte s tím někdo zkušenosti? Tipy, triky na co si dát pozor, kde budou číhat ta největší úskalí?

Díky!

mystik
Člen | 296
+
0
-

To je uz hodne stara verze. Ja postupne upgradoval nekolik vetsich appek z 2.2 na 3.1. Neni to az tolik slozite ale obcas je vyzva najit co vsechno je kde vside potreba upravit. U novejsich verzi muze celkem pomoct Rector s rector-nette rozsirenim. Nette ma taky nejake svoje upgrade tooly a doporucil bych nasadit PHPStan aspon na nejakem nizsim levelu ktery te upozorni na volani neexistujicich metod, nezname typy,…