Pouziti Nette 2.4 vs PHP 7.2

před měsícem

davidzaba
Člen | 8
+
0
-

Ahojte

Rad bych se dotazal, jak pouzivat Nette 2.4 s PHP 7.2. Jde o to, ze Nette 2.4 ma zavislost na Nette\Deprecated a Nette\Deprecated requires php: <7.2.

před měsícem

Šaman
Člen | 2282
+
0
-

Vyjmenovat jednotlivé balíčky v composer.json?
Ale nějak se mi to nezdá – já je vyjmenované nemám a jedu na PHP 7.2.

Editoval Šaman (15. 2. 21:19)

před měsícem

davidzaba
Člen | 8
+
0
-

Šaman napsal(a):

Vyjmenovat jednotlivé balíčky v composer.json?
Ale nějak se mi to nezdá – já je vyjmenované nemám a jedu na PHP 7.2.

Ja mam v composer.json bez vyjmenovani, tj pouze nette 2.4 a pri behu composer install mne to zastavuje, coz me ale fakticky neprekvapuje, jelikoz vidim, ze nette deprecated ma prave ono php < 7.2. Rad bych ale presel na vyssi PHP a tak mozna, jak uvadis, jedine cestou skrze vyjmenovani balicku, i kdyz to neni uplne ono, tak nevim.

před měsícem

ppar
Backer | 195
+
0
-

Ahoj, zkusil jsem pod PHP 7.2 smazat všechny balíčky nette v composer.json a dal jsem jen nette/nette a všechno nainstalovalo v pořádku.

EDIT i pod PHP 7.3

Editoval ppar (15. 2. 22:58)