Nefunguje odosielanie formularov s addUpload v safari

před 11 měsíci

vladimir.biro
Člen | 88
+
0
-

Ahojte.

Od vcera sa mi deje zvlastna vec. Z nicoho nic mi prestalo fungovat odosielanie formularov s nepovinnou moznostou pridania suboru, ale len v pripade, ze subor neprilozim a spracovanie formularu je ajaxove.

Najskor som si myslel ze, ze mam problem niekde u mna, ale potom som vyskusal aj starsie projekty, ktore fungovali a teraz nefunguju.

Nevypise sa ani ziadne chybove hlasenie ani nic podobne. Taktiez ani tracy nic nehlasi. Len klikam na button na odoslanie a nic sa nedeje.

V inom prehliadaci vsetko v pohode funguje. Neviete mi niekto prosim poradit, kde moze byt problem? Ze by mal safari nejake nastavenie niecoho (neviem si ani predstavit coho) ze to potom nejde?

Ak vyberiem nejaky subor, tak tiez v pohode. Dokonca, ked addUpdate nastavim setRequire(‚nieco‘) a nevyberiem subor, tak mi to vyhodi hlasku, ze musim vybrat subor.

No ak mam setRequire(false) a nevyberiem subor, tak sa nic nedeje a formular sa neodosle.

Ajax sa dostane len do stavu before, pretoze sa mi spusti spinner, ale to je vsetko.

Co sa tyka aktualizacie, tak safari sa v poslednej dobe neaktualizoval.

Dakujem za kazdu radu.

Editoval vladimir.biro (17. 4. 2018 17:14)

před 11 měsíci

vladimir.biro
Člen | 88
+
0
-

Este som prisiel aj na to, ze ked mam replicator, tak mi nejde pridavat nove polozky. Tiez sa nic nedeje.

před 11 měsíci

vladimir.biro
Člen | 88
+
0
-

Vidim, ze vela safaristov tu nie je … alebo mam problem niekde inde a nikto podobny problem nema.

před 8 měsíci

ali
Člen | 283
+
0
-

U nas ve firme tedka nastal zrejme stejny problem.. na Safara 10.* to funguje, po aktualizaci na safari 11.* formular se neodesle a console po chvilce vypise error „The network connection was lost.“

před 8 měsíci

ali
Člen | 283
+
+1
-

@vladimir.biro pokud pouzivas nette.ajax.js, tak pro fix pouzij dev-master + tento pull request: https://github.com/…ll/158/files

před 7 měsíci

vladimir.biro
Člen | 88
+
0
-

ali napsal(a):

@vladimir.biro pokud pouzivas nette.ajax.js, tak pro fix pouzij dev-master + tento pull request: https://github.com/…ll/158/files

Dakujem. Vyskusam.