The requested URL /api/www/route/getall was not found on this server

před 5 měsíci

Johnczek
Člen | 37
+
0
-

Zdravím,

řeším nasazení projektu na provoz a nejde mi to.
Vím, že se tento problém řeší často ale zkusil jsem už všechno co se tady nabízelo.

.htaccess v rootu projektu

<?php
<IfModule mod_rewrite.c>
        RewriteEngine On
        RewriteBase /api/
        RewriteRule ^$ www/ [L]
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteCond %{REQUEST_URI} !^www/
        RewriteRule ^(.*)$ www/$1
</IfModule>

Header add Access-Control-Allow-Origin "*"

?>

.htaccess ve www

<?php
# Apache configuration file (see httpd.apache.org/docs/current/mod/quickreference.html)

# disable directory listing
<IfModule mod_autoindex.c>
    Options -Indexes
</IfModule>

# enable cool URL
<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /api/www

    # use HTTPS
    # RewriteCond %{HTTPS} !on
    # RewriteRule .? https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

    # prevents files starting with dot to be viewed by browser
    RewriteRule /\.|^\.(?!well-known/) - [F]

    # front controller
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule !\.(pdf|js|ico|gif|jpg|png|css|rar|zip|tar\.gz|map)$ index.php [L]
</IfModule>

# enable gzip compression
<IfModule mod_deflate.c>
    <IfModule mod_filter.c>
        AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css application/javascript application/json application/xml image/svg+xml
    </IfModule>
</IfModule>

Header and Access-Control-Allow-Origin "*"

?>

mod_rewrite je povolen
composer náležitosti jsou taktéž doinstalovány
práva k log a temp jsou taky nastaveny podle tutoriálu

Apache2.conf

<?php
<Directory />
    Options FollowSymLinks
    AllowOverride None
    Require all denied
</Directory>

<Directory /usr/share>
    AllowOverride None
    Require all granted
</Directory>

<Directory /var/www/>
    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted
</Directory>
?>

(když změním AllowOverride na All tak stránka ani nenaběhne.

Nyní naběhne alespoň /www (je to prázdná stránka jelikož se jedná o API), když chci ale zavolat domena.eu/api/www/routes/getall (což na lokále u xamppu normálně funguje, vyběhne hláška že zadaná URL nebyla nalezena na serveru

Zkoušel jsem už vše co mě napadlo.

před 5 měsíci

Pavel Kravčík
Člen | 909
+
0
-

Pokud na lokále funguje – zkusil bych ještě prověřit velikost písmen. Často třeba začáteční písmeno složky sestřelí celou aplikaci.

před 5 měsíci

Johnczek
Člen | 37
+
0
-

Pavel Kravčík napsal(a):

Pokud na lokále funguje – zkusil bych ještě prověřit velikost písmen. Často třeba začáteční písmeno složky sestřelí celou aplikaci.

Nene velikostí písmen to není.

před 5 měsíci

Johnczek
Člen | 37
+
0
-

Tak už jsem to vyřešil. v .htaccessu byly halvičky se kterýma si apache neuměl poradit. (lze to vyčíst v logu /var/log/apache/errors.log) Tak jsem je smáznul, restartoval apache a už to funguje.