Composer – jak downgradovat konkrétní balík nette na nižší verzi

m.brecher
Backer | 128
+
0
-

Ahoj,

omlouvám se za základní neznalosti, ale potřebuji rychle downgradovat jeden konkrétní balík nette na nižší verzi.

Pomocí composer update jsem aktualizoval celý nette projekt na poslední verze včetně tracy/tracy z verze 2.8.9 na 2.9.0. Hází mě to ale chybu a tak bych potřeboval aktualizovat zpět (včetně všech případných závislostí s jinými balíčky nette) na verzi 2.8.9.

Zkusil jsem v příkazové řádce:

C:\www\cli\karban>composer update tracy/tracy 2.8.9

Loading composer repositories with package information
Package "2.8.9" listed for update is not locked.
Updating dependencies
Nothing to modify in lock file
Installing dependencies from lock file (including require-dev)
Nothing to install, update or remove
.....

Ale downgrade se neprovedl.

Neporadil by někdo ze zkušenějších kolegů? Takovýto downgrade konkrétního balíčku asi musel každý někdy potřebovat.

Díky předem za pomoc.

MajklNajt
Člen | 426
+
0
-

myslím že správne je composer require tracy/tracy:2.8.9

EDIT: require

Editoval MajklNajt (11. 2. 14:39)

m.brecher
Backer | 128
+
0
-

@MajklNajt

Díky, moc, to je ono!

C:\www\cli\karban>composer require tracy/tracy:2.8.9
./composer.json has been updated
Running composer update tracy/tracy
Loading composer repositories with package information
Updating dependencies
Lock file operations: 0 installs, 1 update, 0 removals
  - Downgrading tracy/tracy (v2.9.0 => v2.8.9)
Writing lock file
Installing dependencies from lock file (including require-dev)
Package operations: 0 installs, 1 update, 0 removals
  - Downloading tracy/tracy (v2.8.9)
  - Downgrading tracy/tracy (v2.9.0 => v2.8.9): Extracting archive