dumpe() se refreshuje po 45s

nightoul
Člen | 9
+
0
-

Ahoj, stáhnul jsem testový Nette projekt (pomocí composer create-project nette/web-project) a zarazilo mě, že když si dumpuju v presenterech pomocí dumpe(), tak musím čekat (cca 45 s) než mi tam přiskočí aktuální hodnota. Smazání cache nepomáhá. Tedy např. v HomepagePresenter ve startupu dám dumpe(‚test1‘) a dostanu odpověď hned, pak to změním na dumpe(‚test2‘) a musím čekat než se to aktualizuje. V některých jiných projektech to reaguje hned. Jedná se o čerstvě stažený nette web projekt, pouze v bootstrapu jsem dal setDebugMode(true). Ví někdo, v čem je problém? Díky

Editoval nightoul (22. 1. 11:02)

David Grudl
Nette Core | 7734
+
0
-

A echo 'test2' předpokládám taky nefunguje hned, ne?

nightoul
Člen | 9
+
0
-

Hm, echo se chová divně, chvíli reagovalo okamžitě, když jsem měnil pouze obsah echa v HomepagePresenter actionDefault, pak po smazání actionDefault a echování v bootstrapu už zase nereagovalo. Pak jsem se vrátil ke stejnému pokusu s actionDefault a už echo nereagovalo ani tam.

David Grudl
Nette Core | 7734
+
0
-

Takže asi používáš nějakou opcache nebo něco podobného.

nightoul
Člen | 9
+
0
-

Aha super dik, omrknu :)

EDIT: v souboru .htaccess jsem pridal
php_flag opcache.enable Off

Funguje. Jeste jednou dik

Editoval nightoul (22. 1. 12:57)