Memcache extension is absent – Nette Framework Requirements Checker

m.brecher
Backer | 128
+
0
-

Po instalaci Nette Frameworku verze nette/application 3.1.2, nette/caching 3.1.0 na PHP 8.0.3 jsem spustil Nette Framework Requirements Checker a obdržel chybovou hlášku ohledně memcache:

Memcached extension	- Disabled
Memcache extension is absent. You will not be able to use Nette\Caching\Storages\MemcachedStorage.

Memcached extension instalovanou v PHP nemám a na https://pecl.php.net/ jsem objevil dvě různé memcache extension a nevím, kterou bych měl pro Nette instalovat:

Navíc v php.ini který jsem obdržel s distribucí PHP8 jksem nenašel obvyklý zakomentovaný řádek pro memcache extension, potřeboval bych tedy i poradit, zda je potřeba do php.ini jej ručně dodat.

Poradil by mě někdo ?

Marek Bartoš
Nette Blogger | 720
+
+1
-

nevím, kterou bych měl pro Nette instalovat

memcached – o písmenko víc je ta novější

potřeboval bych tedy i poradit, zda je potřeba do php.ini jej ručně dodat

Zkopíruješ soubor s extension do složky kde jsou ostatní a přidáš řádek do php.ini. Pokud máš linux, tak stačí prosté sudo apt-get install -y php8.0-memcached

Pokud nechceš memcached používat, tak ale nemusíš :) Defaultní cache vytváří php soubory a většinou stačí.
Pokud ji však chceš používat, tak takto:

services:
	cache.storage: Nette\Caching\Storages\MemcachedStorage()
m.brecher
Backer | 128
+
0
-

Marek Bartoš napsal(a):

nevím, kterou bych měl pro Nette instalovat

memcached – o písmenko víc je ta novější

potřeboval bych tedy i poradit, zda je potřeba do php.ini jej ručně dodat

Zkopíruješ soubor s extension do složky kde jsou ostatní a přidáš řádek do php.ini. Pokud máš linux, tak stačí prosté sudo apt-get install -y php8.0-memcached

Pokud nechceš memcached používat, tak ale nemusíš :) Defaultní cache vytváří php soubory a většinou stačí.
Pokud ji však chceš používat, tak takto:

services:
	cache.storage: Nette\Caching\Storages\MemcachedStorage()

@MarekBartoš – díky, můžeš prosím ještě poslat jak by vypadal ten řádek v php.ini? Mám doma Windows, díky moc.

Marek Bartoš
Nette Blogger | 720
+
0
-
extension=memcached

A ujisti se, že používáš správný ini soubor, když spustíš phpinfo();, tak by ti mělo vypsat Loaded Configuration File s cestou k souboru

David Grudl
Nette Core | 7780
+
0
-

Pokud nemáš opravdu dobrý důvod používat memcache, tak ji nepoužívej. Kašli na Requirements Checker.