Instalace contributte/facebook

Mára98
Člen | 47
+
0
-

Dobrý den,

při instalaci contributte/facebook přes composer require contributte/facebook dostávám tuto chybu:

Your requirements could not be resolved to an installable set of packages.

Problem 1
 – Installation request for contributte/facebook ^0.3.0 → satisfiable by contributte/facebook[v0.3.0].
 – contributte/facebook v0.3.0 requires nette/http ~3.0.1 → satisfiable by nette/http[v3.0.1, v3.0.2, v3.0.3, v3.0.3.1, v3.0.4, v3.0.5, v3.0.x-dev] but these conflict with your requirements or minimum-stability.

Nette jsem instaloval přes composer a vše bych měl mít aktuální. Přikládám i svůj composer.json soubor:

{
	"name": "nette/web-project",
	"description": "Nette: Standard Web Project",
	"keywords": ["nette"],
	"type": "project",
	"license": ["MIT", "BSD-3-Clause", "GPL-2.0", "GPL-3.0"],
	"require": {
		"php": ">= 7.2",
		"nette/application": "^3.1",
		"nette/bootstrap": "^3.1",
		"nette/caching": "^3.1",
		"nette/database": "^3.1",
		"nette/di": "^3.0",
		"nette/finder": "^2.5",
		"nette/forms": "^3.1",
		"nette/mail": "^3.1",
		"nette/robot-loader": "^3.3",
		"nette/security": "^3.1",
		"nette/utils": "^3.2",
		"latte/latte": "^2.9",
		"tracy/tracy": "^2.8",
		"nette/http": "^3.1"
	},
	"require-dev": {
		"nette/tester": "^2.3",
		"symfony/thanks": "^1"
	},
	"autoload": {
		"psr-4": {
			"App\\": "app"
		}
	},
	"minimum-stability": "stable"
}

Moc děkuji za jakékoliv rady 🥺

Ondřej Kubíček
Člen | 494
+
0
-

je to tam napsaný contributte/facebook chce nette/http ve verzi 3.0.x, ty máš 3.1.x

Mára98
Člen | 47
+
0
-

Ondřej Kubíček napsal(a):

je to tam napsaný contributte/facebook chce nette/http ve verzi 3.0.x, ty máš 3.1.x

Ahoj, moc děkuji za odpověď. To jsem z toho nějak pochytil, ale když jsem dal:

composer remove nette/http
composer require nette/http:3.0.1

dostal jsem:

Problem 1
 – nette/application v3.1.2 requires nette/http ^3.0.2 → satisfiable by nette/http[v3.0.2, v3.0.3, v3.0.3.1, v3.0.4, v3.0.5, v3.0.x-dev, v3.1.0, v3.1.1, v3.1.x-dev] but these conflict with your requirements or minimum-stability.
 – nette/application v3.1.2 requires nette/http ^3.0.2 → satisfiable by nette/http[v3.0.2, v3.0.3, v3.0.3.1, v3.0.4, v3.0.5, v3.0.x-dev, v3.1.0, v3.1.1, v3.1.x-dev] but these conflict with your requirements or minimum-stability.
 – nette/application v3.1.2 requires nette/http ^3.0.2 → satisfiable by nette/http[v3.0.2, v3.0.3, v3.0.3.1, v3.0.4, v3.0.5, v3.0.x-dev, v3.1.0, v3.1.1, v3.1.x-dev] but these conflict with your requirements or minimum-stability.
 – Installation request for nette/application (locked at v3.1.2, required as ^3.1) → satisfiable by nette/application[v3.1.2].

To je úplně nekonečný příběh, něco upravím a mám konflikt v dalších X závislostech 😔

Ondřej Kubíček
Člen | 494
+
0
-

to ti to mám z angličtiny překládat do češtiny? :D

nette/application v3.1.2 chce nette/http 3.0.2, ty máš ted instalovanou fixně 3.0.1, asi by stačilo prostě nainstalovat dosud poslední 3.0 verzi nette/http 3.0.5

Editoval Ondřej Kubíček (4. 5. 2021 10:55)

jiri.pudil
Nette Blogger | 1008
+
+2
-

Anebo nainstaluj contributte/facebook ve verzi ^0.4@dev a pěkně popros @Felix, aby otagoval stable. V masteru už je totiž závislost na nette/http volnější a bude fungovat i s nejnovějšími verzemi.

Mára98
Člen | 47
+
0
-

Děkuji všem za pomoc! 😊 Nějak jsem si s těma verzema pohrál a už to běží! Moc děkuji všem! <3

cvit84
Člen | 37
+
0
-

Jak jste to zprovoznili potřebuju to taky zprovoznit a nějak mi to nefunguje. Prosím o radu.

Pavel Kravčík
Člen | 1082
+
+1
-

@cvit84: Nějak mi to nefunguje. Kdybych věděl, kde bydlíš, tak Ti hodím kámen do okna. :) Jestli si dobře pamatuji, tak s PHP8 to nefunguje (FB zrušil podporu balíčku, který contributte využívá). Můžeš zkusit league/oauth2-facebook, případně poslat PR s opravou.

cvit84
Člen | 37
+
0
-

Pavel Kravčík napsal(a):

@cvit84: Nějak mi to nefunguje. Kdybych věděl, kde bydlíš, tak Ti hodím kámen do okna. :) Jestli si dobře pamatuji, tak s PHP8 to nefunguje (FB zrušil podporu balíčku, který contributte využívá). Můžeš zkusit league/oauth2-facebook, případně poslat PR s opravou.

Používám php 7.4 Jinak jsem si balíček přes composer nainstaloval ale chtělo by to nějaký lepší manuál, protože jsem docela lama. :(

Pavel Kravčík
Člen | 1082
+
0
-

Manuální je perfektní, viz odkaz

Obecně Ti takhle nikdo neporadí, napiš konkrétní věc, která Ti nejde a co jsi zkoušel. Ale dle druhého příspěvku hádám, že extension, nastavení a DIC pro Tebe ještě není úplně samozřejmost. Zkus udělat třeba quickstart a projet dokumentaci. Pak to třeba bude zřetelnější.

cvit84
Člen | 37
+
-2
-

Se mi podařilo naistalovat tento balíček: league/oauth2-facebook A nechytám se. Ono já poprvé implementuji cizí balíčky mimo nette.

Pavel Kravčík
Člen | 1082
+
0
-

Prostě postup dle toho kódu v dokumentaci

Je to velmi jednoduché, teoreticky to můžeš všechno splácat v jedné akci presenteru. Následně si pak můžeš udělat službu, parametry do konfigu. Zkus být víc konkrétní, co Ti nejde.

$fb = new \League\OAuth2\Client\Provider\Facebook([
			'clientId'          => '',
			'clientSecret'      => '',
			'redirectUri'       => '',
			'graphApiVersion'   => 'v2.10'
		]);
$fb->...

Editoval Pavel Kravčík (23. 2. 14:35)