1. 8 months ago
- David Grudl
- Registered: 2005-02-08
- Posts: 5418
RFC: renamed Nette\Config → Nette\DI
Nette\Config and Nette\DI are very closed namespaces and I think they should be merged to Nette\DI.
Nette\Config\Configurator should be Nette\DI\Configurator or ever better Nette\Configurator, because it is not just DI thing, it configures other parts of framework too, like RobotLoader or Debugger.
And we need some Bridges namespace, where Tracy and (separated) Latte will be connected to framework via compiler extensions. Maybe NetteExtension should be part of this namespace too.